Шпаргалка - установка mercurial с python 2.6 на CentOS 5

Задача

Установить mercurial 2.9 с поддержкой python 2.6
Система - CentOS 5.8

Решение

В пакетную базу CentOS 5 входит python версии 2.4, поэтому установим python 2.6 из репозитория EPEL:

rpm -Uvh http://download.fedoraproject.org/pub/epel/5/i386/epel-release-5-4.noarch.rpm
yum install gcc python26 python26-devel

Шпаргалка - настройка iSCSI initiator для FreeBSD/CentOS

В локальной сети установлен и настроен FreeNAS + iSCSI server
Протокол iSCSI обеспечивает функционал устройств SAN (Storage Attach Network) - позволяет импортировать блочные устройства по TCP/IP протоколам. На узлах требуется установить iSCSI initiator (это клиент) и импортировать разрешённые дисковые блочные устройства для нужд резервного копирования.

iscsi initiator для CentOS

Установка, настройка автозапуска iscsi initiator

yum install iscsi-initiator-utils.x86_64
service iscsi start
chkconfig iscsi on
chkconfig iscsid off

Шпаргалка - установка ImageMagick 6.7.7 на CentOS 5.8

На текущий момент в базовом репозитарии CentOS имеется ImageMagick версии 6.2.8
Пакет ImageMagick 6.7.7 доступен на оф. сайте http://www.imagemagick.org/script/binary-releases.php#unix

Установка дополнительного ПО

Подключим репозиторий RPMForge

cd /tmp/
wget http://packages.sw.be/rpmforge-release/rpmforge-release-0.5.2-2.el5.rf.x86_64.rpm
rpm -Uvh rpmforge-release-0.5.2-2.el5.rf.x86_64.rpm

Установим зависимости для ImageMagick

yum install OpenEXR.x86_64 graphviz.x86_64 fftw3.x86_64 libgomp.x86_64 jasper.x86_64 libtool-ltdl.x86_64 lzma.x86_64

Установка ImageMagick

cd /tmp/
wget http://www.imagemagick.org/download/linux/CentOS/x86_64/ImageMagick-6.7.7-9.x86_64.rpm
rpm -Uvh ./ImageMagick-6.7.7-9.x86_64.rpm

Ссылки

Импорт CentOS errata в Spacewalk

Errata, в моем понимании, - это список пакетов, закрывающих известные уязвимости, либо исправляющие ошибки в предыдущих версиях. Errata также содержит описание конкретной уязвимости и ссылку источник. В Spacewalk существуют:

  • Bugfix Errata
  • Enhancement Errata
  • Security Errata

В данной заметке я опишу как настроить синхронизацию с CentOS errata в вашей системе Spacewalk.

Oracle XE - "ORA-12952: The request exceeds the maximum allowed database size of 4 GB"

Бесплатную версию Oracle XE я использую в связке со Spacewalk. К сожалению, в Oracle XE есть ограничение на размер БД 4Г. Для решения проблемы попробую выполнить процедуру «Compact Storage».

Панель управления Oracle XE висит на удаленном сервере spacewalk.tomtel.ru на localhost:9055, как сменить localhost на 0.0.0.0, чтобы попасть в панель я не знаю, поэтому я создам SSH-туннель:

Выполнить на локальной машине:

ssh -f -N -L 127.0.0.1:9000:127.0.0.1:9055 root@spacewalk.tomtel.ru

После создания туннеля в панель можно зайти с локальной машины по адресу http://localhost:9000/apex/

Посмотреть размер текущих файлов БД

du -sh /usr/lib/oracle/xe/oradata/XE/*

Update

Проблему решил установкой oracle 11gR2 на отдельной машине и переконфигурацией файлов
/etc/rhn/rhn.conf
/etc/rhn/clusters.ini
/etc/tnsnames.ora
на spacewalk.tomtel.ru

Ссылки

 
blog.txt · Последние изменения: 2013/01/23 14:51 — Антон Бугреев · []